/[escript]/trunk/doc/install/srcommon.tex
ViewVC logotype

Diff of /trunk/doc/install/srcommon.tex

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

revision 2511 by jfenwick, Mon Apr 6 23:49:31 2009 UTC revision 2512 by jfenwick, Thu Jul 2 05:34:14 2009 UTC
# Line 17  Line 17 
17    
18  \esfinley is known to compile and run on the following systems:  \esfinley is known to compile and run on the following systems:
19  \begin{itemize}  \begin{itemize}
20   \item \linux under gcc\footnote{There are some problems with OpenMP under gcc prior to version 4.3.2} - \Sec{sec:srclinux}   \item \linux under gcc\footnote{There are some problems with OpenMP under gcc prior to version 4.3.2. Also do not link the gomp library with gcc 4.3.3 it causes problems.} - \Sec{sec:srclinux}
21  \item \linux under icc on SGI ICE 8200.  \item \linux under icc on SGI ICE 8200.
22  \item \macosx under gcc - \Sec{sec:srcmac}  \item \macosx under gcc - \Sec{sec:srcmac}
23  \end{itemize}  \end{itemize}
# Line 32  You must take greater care if downloadin Line 32  You must take greater care if downloadin
32  \begin{itemize}  \begin{itemize}
33   \item python-2.5.1 (\url{http://python.org}) \\   \item python-2.5.1 (\url{http://python.org}) \\
34  - Python  interpreter (You must compile with shared libraries.)  - Python  interpreter (You must compile with shared libraries.)
35  \item numarray 1.5.2 \\ (\url{http://www.stsci.edu/resources/software_hardware/numarray/numarray.html}) \\  \item numpy 1.1.0 (\url{http://numpy.scipy.org})
36  - Arrays for python.  - Arrays for python.
37  \item boost-1.35 (\url{http://www.boost.org}) \\  \item boost-1.35 (\url{http://www.boost.org}) \\
38  - Provides an interface between C++ and python.  - Provides an interface between C++ and python.
# Line 43  You must take greater care if downloadin Line 43  You must take greater care if downloadin
43  The version numbers given here are not strict requirements, more recent (and in some cases older) versions will  The version numbers given here are not strict requirements, more recent (and in some cases older) versions will
44  still work.  still work.
45  The following packages should be sufficient (but not necessarily minimal) for Debian 5.0 (``Lenny''):  The following packages should be sufficient (but not necessarily minimal) for Debian 5.0 (``Lenny''):
46  python-dev, libboost1.35-dev, scons, python-numarray, g++.  python-dev, libboost1.35-dev, scons, python-numpy, g++.
47    
48    
49  These packages may be required for some of the optional capabilities of the system.  These packages may be required for some of the optional capabilities of the system.
# Line 218  Some reasons for this error message incl Line 218  Some reasons for this error message incl
218  Another error we sometimes see is unsatisfied externals when trying to run a python script. This is usually due to not having \texttt{LD_LIBRARY_PATH} and \texttt{PYTHONPATH} set correctly so that you run with different libraries from the ones the code was compiled against. Check which libraries you are running against with \texttt{ldd lib/libfinley.so} and \texttt{ldd esys/finley/finleycpp.so}.  Another error we sometimes see is unsatisfied externals when trying to run a python script. This is usually due to not having \texttt{LD_LIBRARY_PATH} and \texttt{PYTHONPATH} set correctly so that you run with different libraries from the ones the code was compiled against. Check which libraries you are running against with \texttt{ldd lib/libfinley.so} and \texttt{ldd esys/finley/finleycpp.so}.
219    
220  It is also possible that the person who compiled \esfinley used incompatible libraries. For example, if you run with Python2.4 but the software was compiled against Python2.5 then you will get unsatisfied externals or a large error message with a long traceback. Another case is when Boost or Numarray was compiled against the wrong Python library. To avoid these problems everyone (builder and user) must make certain they are using the same python libraries.  It is also possible that the person who compiled \esfinley used incompatible libraries. For example, if you run with Python2.4 but the software was compiled against Python2.5 then you will get unsatisfied externals or a large error message with a long traceback. Another case is when Boost or Numarray was compiled against the wrong Python library. To avoid these problems everyone (builder and user) must make certain they are using the same python libraries.
221    
222    \subsubsection{OpenMP builds segfault running examples}
223    
224    One known cause for this is linking the \filename{gomp} library with escript built using gcc 4.3.3.
225    While you need the -fomp switch you should not need to link \filename{gomp}.

Legend:
Removed from v.2511  
changed lines
  Added in v.2512

  ViewVC Help
Powered by ViewVC 1.1.26